W3C home > Mailing lists > Public > public-fx@w3.org > January to March 2013

Re: comments on Matrix

From: Rik Cabanier <cabanier@gmail.com>
Date: Fri, 22 Mar 2013 11:14:17 -0700
Message-ID: <CAGN7qDA9hp50kFqMQKpxVnxwA444UeSHERvj2Huh+sLOBtGVTg@mail.gmail.com>
To: Benoit Jacob <jacob.benoit.1@gmail.com>
Cc: public-fx@w3.org
On Fri, Mar 22, 2013 at 4:48 AM, Benoit Jacob <jacob.benoit.1@gmail.com>wrote:

> The following points don't seem to have been discussed yet:
> 2013/3/19 Benoit Jacob <jacob.benoit.1@gmail.com>
>> 3. Many concepts are not defined (and their mathematical names aren't
>> that specific).
>> Examples "the skew angle in degrees",
This matches the CSS transforms spec:
Maybe we should make that more clear

> the "perspective" vector, the order of coefficients in a quaternion (is
>> the unit quaternion 1,0,0,0 or 0,0,0,1 in your convention?)
Those have been removed.
They might come back in the pseudo code if we want to add matrix

>> 4. Some method names are verbs, yet they do not perform an action on
>> their object. Example: translate(). I would call that translated(), I
>> suppose.
'translate' can't change because it needs to be compatible with SVG.
As Tab suggest, I'd like to hear what JS people think about this.

What I *think* is open for now:
- clear up skewing, etc by referring to CSS transforms
- look into past tense for method names
- look into adding a matrix interpolation call
- look into matrix decomposition call
- look into an 'IsInvertible' call that determines if the matrix is
reasonably invertible

We can tackle these as separate discussions.
Received on Friday, 22 March 2013 18:14:44 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:49:45 UTC