Re: [editing] Leading with ContentEditable=Minimal

Well stated.  I like contentEditable=cursor.

On Mon, Jun 23, 2014 at 9:21 AM, Robin Berjon <> wrote:

> On 17/06/2014 02:12 , Julie Parent wrote:
>> If Intention events are (temporarily) moved out of scope, I think this
>> leads us back to the question of what would contentEditable='minimal' do
>> exactly?  Enable collapsed selections and default handling of cursor
>> movement ... anything else?  If this is all it would do, then perhaps
>> what we really want is an explicit API to enable cursors?
> The way I see it, that is indeed *all* it would do (and serve as a sanity
> flag so that browsers know how to handle this cleanly).
> It *is* an explicit API to enable cursors. It has the advantage of reusing
> an existing name so that we don't have to worry about what happens when you
> specify both; and it's declarative because that's what you want for such a
> case (notably so that CSS can style what's editable cleanly).
> We could rename it contentEditable=cursor if that's cleaner — the idea is
> the same (and I certainly won't argue bikeshedding :).
> --
> Robin Berjon - - @robinberjon

Received on Monday, 23 June 2014 16:26:24 UTC