Re: [sensors] Introduce WebDriver extension API

A _mock_ variable sounds good to me!

> 5. Let all the _type_ of [Sensor ]( objects' associated [platform sensor ]( be the _type_'s associated [mock sensor](

For this phrase, can probably be improved as: 
> 1. Let _sensor_instance_ be _type_ of Sensor object.
> 5. Set _sensor_instance_' associated [platform sensor]( to _mock_.

Does that make sense to you?

> To be honest, this is pushing my understanding of spec conventions. I think that because these values are not exposed to JavaScript, it's unnecessary to use internal slots. In this case, it may be enough to add text like, "A mock sensor has an associated mock sensor type [...]". The other reviewers can probably answer this question definitively.

Let's keep this as is if there's no more definitive answer from other reviewers. :)

GitHub Notification of comment by Honry
Please view or discuss this issue at using your GitHub account

Received on Thursday, 6 September 2018 05:36:52 UTC