W3C home > Mailing lists > Public > public-data-shapes-wg@w3.org > March 2015

Suggestion: sh:nodeType -> sh:nodeKind

From: Holger Knublauch <holger@topquadrant.com>
Date: Fri, 27 Mar 2015 09:31:26 +1000
Message-ID: <551496CE.1070205@topquadrant.com>
To: RDF Data Shapes Working Group <public-data-shapes-wg@w3.org>
It was good to see some efforts towards test cases. Before we can 
meaningfully do this, we need to agree on the high-level vocabulary to 
be used within those test cases.

As I start to look into filling an unfinished piece in my spec 
(sh:valueType), I noticed that we should rename sh:nodeType so that it 
doesn't conflict with the term "type" in the possible variations of 
sh:valueType, sh:datatype etc. Looking at the RDF spec [1], what we call 
the node types are introduced as:

"There can be three kinds ofnodes 
<http://www.w3.org/TR/rdf11-concepts/#dfn-node>in anRDF graph 
<http://www.w3.org/TR/rdf11-concepts/#dfn-literal>, andblank nodes 

Question: Does anyone object to renaming sh:nodeType to sh:nodeKind? Any 
better proposals?


[1] http://www.w3.org/TR/rdf11-concepts/
Received on Thursday, 26 March 2015 23:32:41 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:30:18 UTC