Re: [csswg-drafts] [css-transitions] Transition to height (or width) "auto" (#626)

Just an idea: What if there was a keyword for `height` (and other properties) that behaved _like_ `auto`, but was a separate keyword which was intended for this purpose specifically:

```css
.item.collapsed {
  height: 20px;
}

.item.expanded {
  height: auto-transitionable; /* probably a better name than this */
}
```

Just wondering if this would make it possible to implement the desired height transition without having to immediately implement all the other things (`calc()`, etc) which make the change to `auto` prohibitively challenging. It could be a known constraint of `auto-transitionable` that it is quirky and shouldn't be used with `calc()`, etc, and shouldn't really be used except to achieve this specific use case. Even if the proposal is kludgey, I would prefer one line of kludgey CSS over a thousand kludgey JS workarounds.

My apologies if this isn't a constructive proposal, as I am not very familiar with the process by which features are integrated into CSS.

-- 
GitHub Notification of comment by pinksynth
Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/626#issuecomment-1017884862 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Thursday, 20 January 2022 20:15:06 UTC