For me the idea in a switch statement is that you have some conditions defining different cases, and you choose the 1st case whose condition holds. That applies to the container queries `switch()`, but not to the `switch()` in this issue. This one is just picking the nth value among a list of values. Calling this `switch()` would be confusing IMO, I agree it needs another name. Maybe something like `pick-nth()`, `nth-value()`, `get-at()` or similar. -- GitHub Notification of comment by Loirooriol Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/5009#issuecomment-626038605 using your GitHub accountReceived on Friday, 8 May 2020 21:57:48 UTC
This archive was generated by hypermail 2.4.0 : Tuesday, 5 July 2022 06:42:06 UTC