[csswg-drafts] Use more succinct names for start/end (#4336)

majido has just created a new issue for https://github.com/w3c/csswg-drafts:

== Use more succinct names for start/end ==
This is a bit of bikeshedding but as I have been building demos based on current API I find that some of the property names used for scroll timeline options are unnecessary verbose. So I suggest the following changes:

- `startScrollOffset` -> `start`
- `endScrollOffset` -> `end`
- `scrollSource` -> `source` (optional)

This first two are particularly important once we also allow element-based start and end concepts (as proposed in https://github.com/WICG/scroll-animations/issues/51) in addition to vanilla scroll offsets: 

That will give you the following IDL
```webidl 
dictionary ScrollTimelineOptions {
  Element? source = null;
  ScrollDirection orientation = "block";
  DOMString start = "auto";
  DOMString end = "auto";
  (double or ScrollTimelineAutoKeyword) timeRange = "auto";
  FillMode fill = "none";
};
```



Please view or discuss this issue at https://github.com/w3c/csswg-drafts/issues/4336 using your GitHub account

Received on Thursday, 19 September 2019 05:40:22 UTC