Re: [csswg-drafts] [selectors4] Name the “functional pseudo-class like :matches() with 0 specificity”

I like `:as()`!
`:case()` is unclear and `:when()` sounds time-related (as I said in the second comment).

At this point, we have been bikeshedding names for a month (9 months if you start counting when the initial proposal was posted). We have seen many proposals, and I don't think a clearly better one will magically emerge if we discuss this for another month. The feature has already started being shared amongst authors, [presented in a Google podcast](, and people are generally excited, so as important as naming is, it would be good not to hold it up further with even more bikeshedding.

I will go ahead and add this to the agenda for next week, so we can do a straw poll and finally decide. Hope that’s ok with you @fantasai!

Here is a summary of all proposals (feel free to edit my comment to add pros & cons, or any proposals I missed):

| Name | Pros | Cons |
| **`:is()`**  | short, meaningful, backronym for "Ignore Specificity".  | logical opposite of `:not()` |
| **`:when()`** | meaningful | looks time-based
| **`:as()`** |short, not opposite of `:not()`
| **`:filter()`** | ? | Confusing, looks related to the CSS filters 
| **`:matches()`** (and renaming `:matches()` to `:is()`) | `:is()` is the logical opposite of `:not()` | Long, browsers have already started implementing `:matches()`
| **`:nospecificity()`** |Explains exactly what it does | Way too long, can't be extended to specify specificity
| **`:extend()`** | ? | Sounds related to `@extend` |
| **`:decorate()`** | ? | Too long, convoluted
| **`:augment()`** | ? | Too long, convoluted, especially for non-native speakers
| **`:if()`** | Short | ?
| **`:catch()`** |  ? | Confusing, Sounds error-related
| **`:apply()`** | ? | ?
| **`:case()`** | ? | ?

GitHub Notification of comment by LeaVerou
Please view or discuss this issue at using your GitHub account

Received on Thursday, 25 January 2018 20:13:12 UTC