Tuesday, 31 March 2015
- [Bug 26586] getCookie method in 12.1.2 is declared as HTTP GET, but contains parameter
- [Bug 28383] New: 'get cookie' is idempotent and should be implemented as a GET not a POST
- [Bug 26295] Page source not defined
- [Bug 20860] WebDriver Level 1
- [Bug 20860] WebDriver Level 1
- [Bug 27645] Document http pre and post conditions that all commands will use
- [Bug 27645] Document http pre and post conditions that all commands will use
- [Bug 20860] WebDriver Level 1
- [Bug 27656] clarify how to send no parameters
- [Bug 27645] Document http pre and post conditions that all commands will use
- [Bug 20860] WebDriver Level 1
- [Bug 27657] clarify that you don't send body with GET requests
- [Bug 20860] WebDriver Level 1
- [Bug 27645] Document http pre and post conditions that all commands will use
- [Bug 27647] Assign http status codes to each error
- [Bug 20860] WebDriver Level 1
- [Bug 26407] Items in "Mapping to HTTP and JSON" section don't contain HTTP methods
- [Bug 26409] Differences between cookie prose and RFC 6265
- [Bug 20860] WebDriver Level 1
- [Bug 28382] New: Send "invalid argument" error if file does not exist
Thursday, 26 March 2015
Thursday, 19 March 2015
Monday, 16 March 2015
Friday, 13 March 2015
- [Bug 20860] WebDriver Level 1
- [Bug 27920] [WebDriver Spec]: takeScreenshot is a GET but what about screenshots of elements??
Wednesday, 11 March 2015
- [Bug 28195] New: It is not specified what error should be raised by findElement(s) operation if an invalid XPath/CSS query passed in
- [Bug 28194] New: Section 8.2.2 ECMAScript should be removed
Monday, 9 March 2015
- Re: [WebDriver] getPageSource - Does it need to be a remote end call?
- Re: [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
- Re: [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
- Re: Are all commands mandatory
- [WebDriver] getPageSource - Does it need to be a remote end call?
Sunday, 8 March 2015
Thursday, 5 March 2015
- [Bug 20860] WebDriver Level 1
- [Bug 28146] [WebDriver Spec]: Add RegExp as valid Javascript Command Parameter type
- [Bug 28146] New: [WebDriver Spec]: Add RegExp as valid Javascript Command Parameter type
- Re: [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
- Re: [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
- Re: Allow navigation to relative URLs?
- Re: "no such element" Error code
- [Bug 28143] New: An option's visibility can be different from the enclosing select visibility
Wednesday, 4 March 2015
- Re: [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
- Re: [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
- Re: [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
Tuesday, 3 March 2015
- Re: [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
- [Bug 20860] WebDriver Level 1
- [Bug 28131] Currently the spec defines switching to window by handle only, does it need by name too?
- "no such element" Error code
- Fwd: [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
- [Bug 28131] New: Currently the spec defines switching to window by handle only, does it need by name too?
Wednesday, 25 February 2015
- Re: Allow navigation to relative URLs?
- Re: Allow navigation to relative URLs?
- Re: Allow navigation to relative URLs?
- Re: Allow navigation to relative URLs?
- Re: Allow navigation to relative URLs?
- Allow navigation to relative URLs?
Thursday, 19 February 2015
- [Bug 28060] New: Should be possible to return errors with executeAsyncScript
- [Bug 27998] Attempt to reuse ended session should result in error response
Wednesday, 18 February 2015
Thursday, 12 February 2015
- Re: Are all commands mandatory
- Are all commands mandatory
- [Bug 28005] New: Define script timeout default
- [Bug 28004] New: Define page load timeout default
- [Bug 28003] New: Page load strategy "conservative" is not described
- [Bug 28002] New: Define maximum number of allowed sessions to facilitate intermediary nodes
Wednesday, 11 February 2015
- Re: Response for close command
- [Bug 27998] New: Attempt to reuse ended session should result in error response
- Response for close command
Monday, 9 February 2015
Saturday, 7 February 2015
Friday, 6 February 2015
Thursday, 5 February 2015
Wednesday, 4 February 2015
- Re: Use cases for local-end set session id?
- Re: Use cases for local-end set session id?
- Use cases for local-end set session id?
Tuesday, 3 February 2015
- [Bug 27951] New: Use null to indicate unlimited script timeout
- [Bug 27950] New: executeScript and executeAsyncScript algorithms should respect the script timeout
- [Bug 27949] New: Script timeout should also apply for synchronous scripts
Monday, 2 February 2015
- Re: [WebDriver] - Section 3 removal.
- Re: [WebDriver] - Section 3 removal.
- [WebDriver] - Section 3 removal.
- [Bug 20860] WebDriver Level 1
- [Bug 27670] rename input device to input source
- [Bug 27669] rename batch to tick
- [Bug 20860] WebDriver Level 1
- [Bug 20860] WebDriver Level 1
- [Bug 27928] [WebDriver Spec]: section 9.1.1 not sure what queryResult is, should show example body response
Friday, 30 January 2015
Thursday, 29 January 2015
- [Bug 20860] WebDriver Level 1
- [Bug 27927] [WebDriver Spec]: section 9.1 uncomprehensible sentence
- [Bug 27928] New: [WebDriver Spec]: section 9.1.1 not sure what queryResult is, should show example body response
- [Bug 27927] New: [WebDriver Spec]: section 9.1 uncomprehensible sentence
- [Bug 27920] [WebDriver Spec]: takeScreenshot is a GET but what about screenshots of elements??
- [Bug 20860] WebDriver Level 1
Wednesday, 28 January 2015
Monday, 26 January 2015
Tuesday, 6 January 2015
- [Bug 27767] New: Unclear what a valid session ID is
- [Bug 27766] New: Clarify whether sessionId is optional from the perspective of the local end before newSession
- [Bug 27765] New: Default value of parameters in command is array