W3C home > Mailing lists > Public > public-audio@w3.org > July to September 2012

[Bug 17724] New: MIDI API naming

From: <bugzilla@jessica.w3.org>
Date: Mon, 09 Jul 2012 17:55:32 +0000
To: public-audio@w3.org
Message-ID: <bug-17724-5429@http.www.w3.org/Bugs/Public/>

           Summary: MIDI API naming
           Product: AudioWG
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: MIDI API
        AssignedTo: dave.null@w3.org
        ReportedBy: jussi.kalliokoski@gmail.com
         QAContact: public-audio@w3.org

Currently, we have MIDIDevice, MIDIInputDevice and MIDIOutputDevice which can
be misleading as they don't necessarily relate to devices per se, but instead
they can be just MIDI ports of a single device. There has been quite a lot of
discussion about this on the list. (Maybe someone/me can add links later, I'm a
bit in a hurry now)

I was thinking about simplifying this a bit; At first I thought about renaming
MIDIDevice to MIDIInterface, but that can be misleading as well, because you
can have multiple ports in a single interface, and sometimes MIDI controllers
are referred to as MIDI interfaces. Hence I'd suggest the following:

MIDIDevice -> MIDIPort
MIDIInputDevice -> MIDIInput
MIDIOutputDevice -> MIDIOutput

Also, Dom pointed out that the 'device' prefix in the properties of the
MIDIDevice interface may be redundant, so I'd suggest we drop that as well.

Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Monday, 9 July 2012 17:55:33 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:50:01 UTC