Re: [Bug 17334] (setTargetValueAtTime): AudioParam.setTargetValueAtTime is misleading and underdefined

Hello, I'm new here.  Please excuse, or freely admonish, if this
comment is more distracting than useful.

Part of what I find confusing, in the spec as it reads, is that the
function signature is divided.

Why not:

AudioParam.set(value, time)
AudioParam.linearRamp(value, time)
AudioParam.exponentialRamp(value, time)
AudioParam.approach(target, time, k)
AudioParam.curve(value_set, time, duration)

or such?

Best,
-rb

On Fri, Jun 29, 2012 at 12:11 AM, Olivier Thereaux
<olivier.thereaux@bbc.co.uk> wrote:
> Hi Chris,
>
>
> On 28/06/2012 19:26, Chris Rogers wrote:
>
>> This is one method in a family of methods which include "AtTime" in
>> their name:
>>
>> setValueAtTime()
>> linearRampToValueAtTime()
>> exponentialRampToValueAtTime()
>> setTargetValueAtTime()
>> setValueCurveAtTime()
>>
>> So I think it's important to maintain consistency here.
>
>
> Yes, good point - we should either keep those as they are or change them
> all.
>
> I note that the methods all use the "atTime" naming convention, rather than
> simply be called setValue, setTargetValue, etc because the latter set of
> names is used for the events. Is that correct?
>
> Olivier
>

Received on Friday, 6 July 2012 07:49:01 UTC