W3C home > Mailing lists > Public > public-aria-editors@w3.org > November 2016

RE: APG build fail

From: Matt King <a11ythinker@gmail.com>
Date: Tue, 8 Nov 2016 09:09:00 -0800
To: "'Michiel Bijl'" <michiel.list@moiety.me>
Cc: "'Michael Cooper'" <cooper@w3.org>, "'ARIA Editors'" <public-aria-editors@w3.org>
Message-ID: <008e01d239e2$cd3d1450$67b73cf0$@gmail.com>
OH, not with travis … totally manual, downloading index.html from rawgit.


For now, I have 2 clones in sibling subdirectories on my system, one with just the gh-pages branch and a main clone with other branches. So, copying examples from master to gh-pages is trivial.


This is not to say that I don’t really miss the automatic build …. It is just survival technique.


On the the topic of respect,  I doubt it has anything to do with the automatic build fails, but the need for browser refresh may be related to the same issue that is effecting the AX tree. I think respect should do all processing in a node that is not displayed. While the processing is happening, it should just display a single node saying “Document being formatted by respect.”. Then, when processing is done, change the display property of the complete document. This would be much more screen reader friendly.




From: Michiel Bijl [mailto:michiel.list@moiety.me] 
Sent: Tuesday, November 8, 2016 8:55 AM
To: Matt King <a11ythinker@gmail.com>
Cc: Michael Cooper <cooper@w3.org>; ARIA Editors <public-aria-editors@w3.org>
Subject: Re: APG build fail


How do you the manual build? Because I don't see the build button Michael talked about. 


On 8 Nov 2016, at 16:47, Matt King <a11ythinker@gmail.com <mailto:a11ythinker@gmail.com> > wrote:

I’ve been building manually for now.


From: Michael Cooper [mailto:cooper@w3.org] 
Sent: Tuesday, November 8, 2016 6:36 AM
To: Michiel Bijl <michiel.list@moiety.me <mailto:michiel.list@moiety.me> >; Matt King <a11ythinker@gmail.com <mailto:a11ythinker@gmail.com> >
Cc: ARIA Editors <public-aria-editors@w3.org <mailto:public-aria-editors@w3.org> >
Subject: Re: APG build fail


I believe this is related to the sporadic non-functionality of Respec that I've been seeing for weeks now. Shane has worked with the systems people on this, and they did something to make it happen less often, but it still happens. In particular, it seems that to get respec-enabled documents to display properly in some browsers it requires a refresh [Chrome] (in other browsers [Firefox] even that doesn't work and it's just random luck as to whether Respec works). Because the spec-generator service doesn't refresh, it just fails. Shane said the spec-generator doesn't use a browser, but it does seem to me to fail in the same frequency that browsers do

I still don't know what is causing the failure - a change in browser security models, some subtle thing in the source of our documents that isn't obvious, a change to W3C anti-denial of service practices, some strange bug in Respec - so I haven't known who to file a bug report with. Shane's attempt to work with the W3C systems people seems to have produced some results but not resolved the problem; I believe they're having a hard time duplicating the problem even though I see it on nearly every document I work with. 

I've been thinking of trying to come up with a workaround to this, by including Respec as a library in our repositories rather than pointing to its location on the W3C server, but until I get the aria-common library working I won't know how to make that work. I've also thought of trying to install the spec generator locally within the build script rather than rely on the online version (that fails a lot in the best of circumstances), but the documentation is atrocious and I can't figure out how to get started. It's all on my todo list, and perhaps I need to escalate with more knowledgeable people.

In the meantime, since the problem seems to be sporadic, you can always try to restart the build. For practices, go to https://travis-ci.org/w3c/aria-practices/ and hit "Restart build". I just tried this and it didn't work, but sometimes I have seen it work.



On 08/11/2016 8:32 AM, Michiel Bijl wrote:



Ever since pull request #147 <https://github.com/w3c/aria-practices/issues/147>  was merged into master the build is failing again. I’m not quite sure how to fix this, but could somebody look at it? If you know what it is I’d love to learn for next time this happens.



Received on Tuesday, 8 November 2016 17:09:35 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 8 November 2016 17:09:35 UTC