W3C home > Mailing lists > Public > xproc-dev@w3.org > February 2011

RE: p:exec -- can it apply to only selected parts of input using a loop?

From: Hans-Juergen Rennau <rennau@bits-ac.com>
Date: Wed, 02 Feb 2011 12:25:04 +0100
Message-ID: <4D493F10.3040801@bits-ac.com>
To: XProc Dev <xproc-dev@w3.org>
Hi Alex,

emphatically agreed - the word viewport has always been a mystery to me. 
Always will be. The only way out, for me, is learning it by heart.

I think you are right in caring about names. After all - what the step 
does is simply updating the document, in a way which is simplified by 
identifying target fragments and "forgetting" the rest - restricted, 
local updates, so to speak. Therefore your proposals make sense to me.

Regards,
Hans-Juergen

PS: Perhaps p:modifyNodes is better than p:modifyNode? Often it is a set 
of nodes what is edited. Or perhaps p:localUpdates?


Alex wrote:

...

btw is there a way to vote for changing the name of p:viewport

I'm not certain if the graphics terminology influenced the naming or if 
that is coincidence http://en.wikipedia.org/wiki/Viewport

What would a developer think p:viewport does intuitively?  If random xml 
developer not familiar with xproc was asked what they were going to do 
when viewing a port on their xml input what would they say?

There may be a better term related to what is happening with the xml 
input such that a selection of the document is being modified.

p:modifySubtree
p:modifyNode

Maybe p:modifyNode is the most intuitive I can come up with 
brainstorming here..

Let me know your thoughts
Regards
Received on Wednesday, 2 February 2011 11:25:37 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 2 February 2011 11:25:53 GMT