W3C home > Mailing lists > Public > xmlschema-dev@w3.org > July 2003

RE: Schema include problem [solved]

From: David Balch <david.balch@continuing-education.oxford.ac.uk>
Date: Tue, 15 Jul 2003 15:57:25 +0100
Message-ID: <CCDA876B4148874F8F554995799FF1FB2074D4@springbok.conted.ox.ac.uk>
To: "'ht@cogsci.ed.ac.uk'" <ht@cogsci.ed.ac.uk>
Cc: "'xmlschema-dev@w3.org'" <xmlschema-dev@w3.org>

Hi Henry,

> From: ht@cogsci.ed.ac.uk [mailto:ht@cogsci.ed.ac.uk]

> You have to work through the errors one at a time, and make sure
> you're not missing any.  When I ran xsv locally against your instance,
> it complained that content-v04.xsd was using lom: without importing
> it.  I fixed that (with 
> <xs:import namespace="http://www.imsglobal.org/xsd/imsmd_rootv1p2p1"
>            schemaLocation="imsmd_rootv1p2p1.xsd"/>

Right, done that now. I had thought that it was ok (as I import it into the
hub), evidently I need to import it into the content-v0.4.xsd as well.

> 
> The remaining errors all look like real errors to me, and indeed there
> _is_ no declaration of an element called 'learningObject', so XSV is

D'oh! I've been looking at this on and off for a couple of days, and the
problem turns out to be a typo - how very annoying.
The good side is that (aside from the real errors) it now works. Well
spotted :-)

Many thanks for your help,
Dave.


> correct to report that it found no declaration for the document
> element.
> 
> ht
> -- 
>   Henry S. Thompson, HCRC Language Technology Group, 
> University of Edinburgh
>                       Half-time member of W3C Team
>      2 Buccleuch Place, Edinburgh EH8 9LW, SCOTLAND -- (44) 
> 131 650-4440
> 	    Fax: (44) 131 650-4587, e-mail: ht@cogsci.ed.ac.uk
> 		     URL: http://www.ltg.ed.ac.uk/~ht/
>  [mail really from me _always_ has this .sig -- mail without 
> it is forged spam]
> 
Received on Tuesday, 15 July 2003 10:57:52 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 11 January 2011 00:14:39 GMT