W3C home > Mailing lists > Public > xmlschema-dev@w3.org > December 2002

content model error?

From: Dennis Landi <dennis@dennislandi.com>
Date: Tue, 3 Dec 2002 12:04:50 -0500
Message-ID: <066401c29aee$18640fe0$a06c3318@DSI.distributedinc.com>
To: <xmlschema-dev@w3.org>

Hello,

I am trying to validate a doc against a schema using Excelon Stylus Studio
(nice product).

I am getting this error:

Element 'NFField' is not valid for content model: ''

For line:

<NFField Sequence="01" Requirement="Rx" FieldName="Rec_Type" Length="3"
DataType="String" Description="Record Type Value: CVR" Null="False"/>


Here is the spec for NFField from my schema:

 <xsd:element name="NFField" nillable="true">
  <xsd:complexType mixed="true">
   <xsd:sequence>
   <xsd:any namespace="http://www.w3.org/namespace/"/>
   </xsd:sequence>
   <xsd:attribute name="Sequence" type="xsd:string" use="required"/>
   <xsd:attribute name="Requirement" type="xsd:string" default="required"/>
   <xsd:attribute name="FieldName" type="xsd:string" use="required"/>
   <xsd:attribute name="Length" type="xsd:string" use="required"/>
   <xsd:attribute name="DataType" type="xsd:string" use="required"/>
   <xsd:attribute name="Description" type="xsd:string" use="required"/>
   <xsd:attribute name="Null" type="xsd:string" use="required"/>
  </xsd:complexType>
 </xsd:element>

What am I doing wrong?

-dennis
Received on Tuesday, 3 December 2002 12:44:04 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 11 January 2011 00:14:35 GMT