W3C home > Mailing lists > Public > xml-dist-app@w3.org > October 2002

Re: Proposal for new last call issue: Some unprocessed headers should stay

From: Jean-Jacques Moreau <moreau@crf.canon.fr>
Date: Mon, 21 Oct 2002 11:41:18 +0200
Message-ID: <3DB3CBBE.1080205@crf.canon.fr>
To: Jacek Kopecky <jacek@systinet.com>
CC: Henrik Frystyk Nielsen <henrikn@microsoft.com>, Martin Gudgin <mgudgin@microsoft.com>, Noah Mendelsohn <noah_mendelsohn@us.ibm.com>, XMLP Dist App <xml-dist-app@w3.org>

What I think we are loosing with role="relay" is the ability to 
give meaningful/useful names to roles, such as, for example, 
"cacheManager".

At the extreme, why not limit the value of the "role" attribute 
to either "next", "relay" and "ultimateReceiver"? Isn't the 
header itself (QName) sufficient for targetting?

The "relayIfNotProcessed" option preserves the status quo better, 
IMO: headers can continue to be targetted via meaningful role 
names, with the added option of describing relaying semantics.

Jean-Jacques.

Jacek Kopecky wrote:

>  > >3) targeting the first understanding node
>  > 	Role="relay"
>  > 	Header block does not define relaying of that block
>
> It is necessary that the understanding node plays the special 
> role, and as I believe this would either lead to virtually all 
> nodes in any system playing this role or to possible conflicts 
> if two different headers wanted to use the relaying semantics 
> on two different sets of nodes along the message path.
Received on Monday, 21 October 2002 05:41:13 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:59:11 GMT