W3C home > Mailing lists > Public > www-xml-schema-comments@w3.org > July to September 2010

[Bug 10470] New: Incomplete integration of paths to particles and attribute uses

From: <bugzilla@jessica.w3.org>
Date: Fri, 27 Aug 2010 14:52:47 +0000
To: www-xml-schema-comments@w3.org
Message-ID: <bug-10470-703@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=10470

           Summary: Incomplete integration of paths to particles and
                    attribute uses
           Product: XML Schema
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: SCDS: XML Schema Component Designators
        AssignedTo: holstege@mathling.com
        ReportedBy: holstege@mathling.com
         QAContact: www-xml-schema-comments@w3.org


(Summary of detailed comments sent by Sandy Gao)

The model is that particles and attribute uses in the component
model act as if they aren't there for path purposes, so whatever arcs there are
coming from a particle, its just as if it came from the prior component.  This
was less than clear in the description, but now that we have explicitly added
axes that navigate to those components, it is REALLY unclear.  And it leaves
the status of canonical paths for annotations on particles and attribute uses
really really unclear. 

Related to parts of #10469

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Friday, 27 August 2010 14:52:51 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 14:50:10 UTC