W3C home > Mailing lists > Public > www-xml-schema-comments@w3.org > October to December 2009

[Bug 8342] New: Bring wording wrt duplicate attribute decls into line

From: <bugzilla@wiggum.w3.org>
Date: Fri, 20 Nov 2009 14:44:15 +0000
To: www-xml-schema-comments@w3.org
Message-ID: <bug-8342-703@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=8342

           Summary: Bring wording wrt duplicate attribute decls into line
           Product: XML Schema
           Version: 1.1 only
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Structures: XSD Part 1
        AssignedTo: David_E3@VERIFONE.com
        ReportedBy: ht@inf.ed.ac.uk
         QAContact: www-xml-schema-comments@w3.org
                CC: cmsmcq@blackmesatech.com


Further to a point raised by Sandy Gao at
http://www.w3.org/Bugs/Public/show_bug.cgi?id=8119#c4, I think we should make a
modest correction.

At the moment, in the section on Attribute Groups [1], we have

  "No two distinct members of the {attribute uses} have
   {attribute declaration}s with the same expanded name."

whereas in the section on Complex Type Definitions [2], we have

  "No two distinct attribute declarations in the {attribute uses}
   have identical expanded names."

I think we should use the same wording in both cases, and I think the first
wording is the right wording.

ht

[1] http://www.w3.org/TR/xmlschema11-1/#coss-attrGroup
[2] http://www.w3.org/TR/xmlschema11-1/#sec-ct-props-correct


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Friday, 20 November 2009 14:44:24 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Sunday, 6 December 2009 18:13:19 GMT