W3C home > Mailing lists > Public > www-ws-desc@w3.org > December 2006

RE: Comment on Fragment Identifiers

From: Jonathan Marsh <jonathan@wso2.com>
Date: Thu, 21 Dec 2006 14:20:27 -0800
To: "'Ashok Malhotra'" <ashok.malhotra@oracle.com>, <www-ws-desc@w3.org>
Cc: <public-ws-policy@w3.org>
Message-ID: <002f01c7254e$645cf940$3401a8c0@DELLICIOUS>

Ashok,

Besides the answers to this mail you received to your query, the WG briefly
discussed your suggestion and confirmed today that we will not move the
message label on WSDL 2.0 component designators into the fragment scheme
name, since in WSDL 2.0 the message labels are not limited to "in" or "out".
These tokens are defined by the message exchange pattern in place, and we
support extended message exchange patterns.  This design supports that
extensibility (even though we're not using it within WSDL 2.0 ourselves).

The WG expressed no preference on whether your suggested redesign was a
benefit for WSDL 1.1 component designators, where there isn't support for
MEP extensibility.  We note that if consistency with WSDL 2.0 component
designators is paramount, keeping this redundant information in the format
would be desirable.  Yet if simplicity is paramount, removing the redundant
information as you suggest would be natural.

Jonathan Marsh - http://www.wso2.com - http://auburnmarshes.spaces.live.com
 

> -----Original Message-----
> From: www-ws-desc-request@w3.org [mailto:www-ws-desc-request@w3.org] On
> Behalf Of Ashok Malhotra
> Sent: Wednesday, December 13, 2006 2:08 PM
> To: www-ws-desc@w3.org.
> Cc: public-ws-policy@w3.org
> Subject: RE: Comment on Fragment Identifiers
> 
> 
> Resending.  Last attempt was truncated.
> 
> As you may know, the WS-Policy WG has been doing some work on defining
> element identifiers for WSDL 1.1 elements.  We are trying to align this
> work with the WSDL 2.0 fragment identifiers described in Appendix A.2 of
> the WSDL 2.0 Candidate Recommendation draft of 2006-03-27.
> 
> In looking at Appendix A.2 I came across two situations where I think the
> syntax can be improved.  Consider
> 	wsdl.interfaceMessageReference(interface/operation/message)
> this fragment identifier takes 3 parameters.  The first two take names as
> values while the third takes a message label whose value can only be
> "input" or "output".  Having a parameter that takes a keyword as value
> seems foreign to the general design in which parameters take names as
> values.  Thus, I suggest that the label be added to the name of the
> fragment identifier and it have only two parameters, thus:
> 	wsdl.interfaceMessageInput(interface/operation)
> 	wsdl.interfaceMessageOutput(interface/operation)
> 
> The following row in the table can also be improved.
>  	wsdl.interfaceFaultReference(interface/operation/message/fault)
> can be replaced by two identifiers
>  	wsdl.interfaceInFault(interface/operation/fault)
> 	wsdl.interfaceInFault(interface/operation/fault)
> 
> Similar suggestions apply to
> 	wsdl.bindingMessageReference(binding/operation/message) and
> 	wsdl.bindingFaultReference(binding/operation/message/fault)
> 
> I hope you will consider these changes.
> 
> All the best, Ashok
Received on Thursday, 21 December 2006 22:21:22 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:58:43 GMT