RE: proposal: minor syntax improvement for soap fault bindings

thanks! i further suggest applying Jacek's rule of never 
having an element or attribute called 'value' and hoist the 
code and subcode attributes into fault meaning:
    <fault ref="xs:QName" >
      <documentation />?
      <wsoap:code>
        <wsoap:value>xs:QName</wsoap:value>
        <wsoap:subcode>
          <wsoap:value>xs:QName</wsoap:value>
          <wsoap:subcode>...</wsoap:subcode>
        </wsoap:subcode>?
      </wsoap:code>
    </fault>*
becomes:
    <fault ref="xs:QName" 
         wsoap:code="xs:QName" 
         wsoap:subcodes="list of xs:QName" />
      <documentation />?
    </fault>*
downside is we can no longer document individual fault codes, 
but that seems to be no great loss to me since this is all 
about grouping and routing codes to a meaningful interface fault.
Paul
 

 -----Original Message----- 
 From: www-ws-desc-request@w3.org on behalf of Prasad Yendluri 
 Sent: Thu 06/05/2004 19:05 
 To: www-ws-desc@w3.org 
 Cc: 
 Subject: Re: proposal: minor syntax improvement for soap fault bindings
 
 
 I guess we kinda settled on the original proposal from Sanjiva on the call today but, I like this improvement. It satisfies the intent of Roberto's suggestion while keeping the separation between code and sub-codes.
 
 Prasad
 
 -------- Original Message -------- 
Subject:  RE: proposal: minor syntax improvement for soap fault bindings 
Resent-Date:  Thu, 6 May 2004 12:39:37 -0400 (EDT) 
Resent-From:  www-ws-desc@w3.org 
Date:  Thu, 6 May 2004 17:39:07 +0100 
From:  <paul.downey@bt.com> <mailto:paul.downey@bt.com>  
To:  <Roberto.Chinnici@Sun.COM> <mailto:Roberto.Chinnici@Sun.COM> , <sanjiva@watson.ibm.com> <mailto:sanjiva@watson.ibm.com>  
CC:  <www-ws-desc@w3.org> <mailto:www-ws-desc@w3.org>  

 as suggested, verbally on the telcon:
 
    <wsoap:code value="xs:QName" subcodes="list of xs:QName" />
 
 solves the problem of the first value having a different meaning 
 to the rest of the list.
 
 Paul
 
 
 -----Original Message-----
 From: www-ws-desc-request@w3.org [mailto:www-ws-desc-request@w3.org]On
 Behalf Of Roberto Chinnici
 Sent: 04 May 2004 01:05
 To: Sanjiva Weerawarana
 Cc: www-ws-desc@w3.org
 Subject: Re: proposal: minor syntax improvement for soap fault bindings
 
 
 
 How about a further improvement? Instead of
 
        <wsoap:code value="xs:QName">
          <wsoap:subcode value="xs:QName">
            <wsoap:subcode>...</wsoap:subcode>
          </wsoap:subcode>?
        </wsoap:code>
 
 we do:
 
        <wsoap:code value="list of xs:QName">
        </wsoap:code>
 
 I.e. the value of @code is a list of QNames, the first one being
 the code and the other ones its subcodes. And of course we cshould
 constrain the list to have length > 0.
 
 Roberto
 
 
 Sanjiva Weerawarana wrote:
 > I suggest we move wsoap:code/wsoap:value to an attribute:
 > 
 > That is, instead of:
 > 
 >       <wsoap:code>
 >         <wsoap:value>xs:QName</wsoap:value>
 >         <wsoap:subcode>
 >           <wsoap:value>xs:QName</wsoap:value>
 >           <wsoap:subcode>...</wsoap:subcode>
 >         </wsoap:subcode>?
 >       </wsoap:code>
 > 
 > we do:
 > 
 >       <wsoap:code value="xs:QName">
 >         <wsoap:subcode value="xs:QName">
 >           <wsoap:subcode>...</wsoap:subcode>
 >         </wsoap:subcode>?
 >       </wsoap:code>
 > 
 > This makes the syntax more consistent with the rest of the
 > SOAP binding which is rather attribute-heavy.
 > 
 > Sanjiva.

Received on Friday, 7 May 2004 05:14:51 UTC