W3C home > Mailing lists > Public > www-ws-desc@w3.org > January 2004

Confusion between binding and element names

From: Yaron Goland <ygoland@bea.com>
Date: Thu, 22 Jan 2004 15:08:17 -0800
To: <www-ws-desc@w3.org>
Message-ID: <02bb01c3e13c$9fb40b90$65e5e40c@bea.com>

Some of the children of the interface and binding XML elements, specifically
the XML elements operation, input, output, infault and outfault, use the
same names but have different, although related, meanings in the two
locations.

It would be friendlier to those writing WSDLs, especially to those talking
about WSDLs, if slightly different names were used.

For example, one can imagine that the names for the children of interface
would stay the same but the children of binding would change to
bindOperation, bindInput, bindOutput, bindInFault, bindOutFault and
bindMessageReference.

This small change would make simple sentences such as "The second infault
has an error" much clearer as one would know that an interface was being
discussed.

	Thanks,

		Yaron
Received on Thursday, 22 January 2004 18:12:31 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:58:28 GMT