W3C home > Mailing lists > Public > www-ws-desc@w3.org > August 2004

Re: Editorial for Part 1 section 2.18

From: Umit Yalcinalp <umit.yalcinalp@oracle.com>
Date: Tue, 03 Aug 2004 15:12:10 -0700
Message-ID: <41100DBA.2080800@oracle.com>
To: Arthur Ryman <ryman@ca.ibm.com>
Cc: www-ws-desc@w3.org


Arthur Ryman wrote:

>
> Martin,
>
> I agree. I think that targetNamespace is a misnomer. It makes sense in 
> the definitions element, but not in the component model. Components 
> have QNames. I'd like to make the following editorial suggestion to 
> improve the naming and simplify the component model.
>
> In the following components, remove the targetNamespace property and 
> change the name property to be a QName instead of an NCName:
>
> Intertace
> InterfaceFault
> InterfaceOperation
> Binding
> Service

Arthur,

What you are suggesting will make the defn of operations inconsistent 
with the rest of the component model. Operations are local to an 
interface, therefore we can not apply the same "simplification" to them.

At present, the components are at least utilizing the pair of properties 
and at least they are consistent. Therefore, I don't think this change 
is necessary.

Cheers,

--umit



>
> Arthur Ryman,
> Rational Desktop Tools Development
>
> phone: +1-905-413-3077, TL 969-3077
> assistant: +1-905-413-2411, TL 969-2411
> fax: +1-905-413-4920, TL 969-4920
> mobile: +1-416-939-5063
> intranet: http://w3.torolab.ibm.com/DRY6/

Cheers,

--umit

>
>
> "Martin Gudgin" <mgudgin@microsoft.com>
> Sent by: www-ws-desc-request@w3.org
>
> 08/03/2004 06:00 AM
>
> 	
> To
> 	"Bijan Parsia" <bparsia@isr.umd.edu>, <www-ws-desc@w3.org>
> cc
> 	
> Subject
> 	RE: Editorial for Part 1 section 2.18
>
>
>
> 	
>
>
>
>
>
>
> I believe the property used to be called {namespace name} and was
> populated with the value of wsdl:definitions/@targetNamespace.
> Personally, I think {namespace name} is the better name, as the property
> is NOT a *target* namespace when it appears on an interface component (
> or any other component for that matter ). To my mine, the notion of
> target namespace is purely a serialization detail.
>
> Gudge
>
> > -----Original Message-----
> > From: www-ws-desc-request@w3.org
> > [mailto:www-ws-desc-request@w3.org] On Behalf Of Bijan Parsia
> > Sent: 03 August 2004 10:53
> > To: www-ws-desc@w3.org
> > Subject: Editorial for Part 1 section 2.18
> >
> >
> > "2.18 QName resolution
> >
> > In its serialized form WSDL makes significant use of
> > references between
> > components. Such references are made using the Qualified Name, or
> > QName, of the component being referred to. QNames are a tuple,
> > consisting of two parts; a namespace name and a local name. For
> > example, in the case of an Interface component, the namespace name is
> > represented by the {namespace name} property and the local name is
> > represented by the {name} property."
> >
> > I can't find any {namespace name} *property* (component).
> > Perhaps it is
> > the {targetNamespace}?
> >
> > I see lots of references to [namespace name] Infoset properties.
> >
> > Ah, I see in 2.17:
> >
> > "Within a symbol space, all qualified names (that is, the combination
> > of {name} and {target namespace} properties) are unique.
> > Between symbol
> > spaces, the combination of these two properties need not be unique.
> > Thus it is perfectly coherent to have, for example, a binding and an
> > interface that have the same name."
> >
> > This suggests that it is {targetNamespace}.
> >
> > Cheers,
> > Bijan Parsia.
> >
> >
>
>

-- 
Umit Yalcinalp                                  
Consulting Member of Technical Staff
ORACLE
Phone: +1 650 607 6154                          
Email: umit.yalcinalp@oracle.com
Received on Tuesday, 3 August 2004 18:14:21 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:58:32 GMT