W3C home > Mailing lists > Public > www-ws-desc@w3.org > October 2003

Re: [rev 0] Agenda, 3-5 Nov 2003 WSDesc FTF

From: Sanjiva Weerawarana <sanjiva@watson.ibm.com>
Date: Tue, 28 Oct 2003 01:16:15 +0600
Message-ID: <076401c39cbe$cccc0d70$36356a20@lankabook2>
To: "Jonathan Marsh" <jmarsh@microsoft.com>, <www-ws-desc@w3.org>

Hi Jonathan,

Please add the following to the upcoming telecon or F2F agenda.
I'd like to get at least the first two issues resolved at the telecon
so that the spec can be updated and ready accordingly.

- currently interface/operation/(input|output)/@messageReference
  is optional
  That doesn't make any sense with what we have now. Mark REQUIRED.

- <infault>/<outfault> vs. <fault>.
  See http://lists.w3.org/Archives/Public/www-ws-desc/2003Oct/0177.html
  for problem with current design.

- binding different fault details differently (for same @messageRef
  value)
  Current proposal is to add optional @name NCName. Alternate approach
  is to allow optional /definitions/binding/operation/fault/@details
  to be the selector. 
  I AM STILL NOT CONVINCED THIS IS NECESSARY (NO USE-CASES), but if
  necessary this seems to be least cost solution. YMMV.

- {direction} properties of message and fault reference components
  are ficticious in both interface/operation and binding/operation.
  Proposal: delete.

In addition, I am going to make a proposal for an updated definition
of equivalence to enable greater loose coupling between the service
and its consumer. Please put me on the F2F agenda for that.

> 10:50 Issue #88 [31] Rename "operation" to "messageExchange" (again!?).
>     Deferred while thread is running [32]

IMO we've discussed this enough times and rejected it enough times.
If at all, let's put it on a telecon rather than F2F please.

Sanjiva.
Received on Monday, 27 October 2003 14:19:08 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:58:27 GMT