W3C home > Mailing lists > Public > www-ws-desc@w3.org > October 2003

Re: PROPOSAL: Drop interface/operation/(input|output)/@headers

From: Roberto Chinnici <Roberto.Chinnici@Sun.COM>
Date: Tue, 21 Oct 2003 10:14:02 -0700
To: Sanjiva Weerawarana <sanjiva@watson.ibm.com>
Cc: www-ws-desc@w3.org
Message-id: <3F95695A.4020802@sun.com>


I'm in favor of this proposal, but I think it should be conditional
on features/properties being fully clarified and understood.

Till then, I'd prefer to keep @headers in, so that we don't risk
ending up with a net loss of functionality.

The third change you propose, i.e.
 >     - rename interface/operation/(infault|outfault)/@details to
 >       interface/operation/(infault|outfault)/@message
doesn't affect headers, so I'm +1 on doing it straight away.


Roberto Chinnici
Java Web Services
Sun Microsystems, Inc.

Sanjiva Weerawarana wrote:
> During the <message> elimination process, I proposed that it be
> eliminated by introducing a single element that may go as the 
> body of the message and zero or more "header" elements. The motivation
> was that it was possible in WSDL 1.1 to have such header and body
> parts and we didn't want to lose that functionality.
> The main use of the "header" parts are to enable one to use WSDL
> to describe middleware protocol type "applications" of WSDL. That
> is, one can imagine protocols requiring certain headers to be 
> present etc..
> However, to fully describe such protocols the header stuff has to
> be much much richer. If you look at the original context proposal
> I made back in January this year, you'll see some of that richness,
> but even that is not enough.
> At the same time, complicating WSDL to the extent needed to make
> it possible to fully describe a handful of middleware protocols
> when compared to the millions of "regular" applications doesn't
> seem like the right tradeoff. 
> Thus, we now propose we drop the "headers" concept from input and
> output messages. Messages will simply be a single XML element. 
> I also propose a simple syntactic change to exploit this new 
> simplified structure of messages. Rather than the current form:
>     <input messageReference="xs:NCName" 
>            body="xs:QName"? headers="list of xs:QName"?/>
> I suggest we use:
>     <input messageReference="xs:NCName" 
>            message="xs:QName"/>
> And similarly for <output>. The same syntactic approach can be
> used to make <fault>s consistent with this approach. Rather the
> current form:
>     <infault messageRefernce="xs:NCName" details="xs:QName"/>
> I suggest we use:
>     <infault messageReference="xs:NCName" message="xs:QName"/>
> And similarly for <outfault>.
> Thus, this email proposes the following changes to status quo:
>     - drop interface/operation/(input|output)/@headers
>     - rename interface/operation/(input|output)/@body to
>       interface/operation/(input|output)/@message
>     - rename interface/operation/(infault|outfault)/@details to
>       interface/operation/(infault|outfault)/@message
> Sanjiva.
Received on Tuesday, 21 October 2003 13:17:54 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:54:44 UTC