W3C home > Mailing lists > Public > www-ws-desc@w3.org > December 2003

Proposal: rename "asynch-output-input"

From: Amelia A Lewis <alewis@tibco.com>
Date: Mon, 01 Dec 2003 14:12:12 -0500
To: WS Description List <www-ws-desc@w3.org>
Message-id: <20031201141212.0ca29737.alewis@tibco.com>

I made a misstep in naming one of the added patterns, using the term
"asynch" because I couldn't, at the time, think of a better
distinguisher.

A name that better fits the pattern used throughout part two would be:
"output-optional-input".  That is, output followed by (optional) input. 
This helps distinguish it from the output-input pattern (where input is
required), but does not give the (misleading) impression that it can
only be used in an asynchronous environment (although it *is* true that
using output-optional-input in a synchronous environment is a bear with
cubs).

Amy!
-- 
Amelia A. Lewis
Architect, TIBCO/Extensibility, Inc.
alewis@tibco.com
Received on Monday, 1 December 2003 14:12:11 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:58:27 GMT