W3C home > Mailing lists > Public > www-ws-desc@w3.org > December 2003

Re: Proposal: rename "asynch-output-input"

From: Sanjiva Weerawarana <sanjiva@watson.ibm.com>
Date: Tue, 2 Dec 2003 21:02:06 +0600
Message-ID: <0b8901c3b8e5$4a554670$72545ecb@lankabook2>
To: "Amelia A Lewis" <alewis@tibco.com>, "WS Description List" <www-ws-desc@w3.org>

+1; asynch is such a loaded word that its best to avoid it as
much as possible. 

Sanjiva.

----- Original Message ----- 
From: "Amelia A Lewis" <alewis@tibco.com>
To: "WS Description List" <www-ws-desc@w3.org>
Sent: Tuesday, December 02, 2003 1:12 AM
Subject: Proposal: rename "asynch-output-input"


> 
> I made a misstep in naming one of the added patterns, using the term
> "asynch" because I couldn't, at the time, think of a better
> distinguisher.
> 
> A name that better fits the pattern used throughout part two would be:
> "output-optional-input".  That is, output followed by (optional) input. 
> This helps distinguish it from the output-input pattern (where input is
> required), but does not give the (misleading) impression that it can
> only be used in an asynchronous environment (although it *is* true that
> using output-optional-input in a synchronous environment is a bear with
> cubs).
> 
> Amy!
> -- 
> Amelia A. Lewis
> Architect, TIBCO/Extensibility, Inc.
> alewis@tibco.com
Received on Tuesday, 2 December 2003 10:01:56 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:58:27 GMT