W3C home > Mailing lists > Public > www-webont-wg@w3.org > January 2003

Re: ISSUE: owl:Class name misleading; try owl:Set?

From: Jeff Heflin <heflin@cse.lehigh.edu>
Date: Thu, 02 Jan 2003 09:53:14 -0500
Message-ID: <3E14525A.F4D1DBA9@cse.lehigh.edu>
To: "Peter F. Patel-Schneider" <pfps@research.bell-labs.com>
CC: connolly@w3.org, www-webont-wg@w3.org

"Peter F. Patel-Schneider" wrote:
> owl:sameMember[s]As might be a better name for owl:sameClassAs.

I agree that sameClassAs is a very misleading name. At the very least,
we need to mention in the Guide and the Reference that it only means
that the extensions of two classes are equal. In particular we need to
point out that it does not mean that the property values of two classes

However, it would be far better to not have a confusing name. Therefore,
I would strongly support renaming sameClassAs to either sameMembersAs or

Received on Thursday, 2 January 2003 09:53:20 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:56:50 UTC