W3C home > Mailing lists > Public > www-webont-wg@w3.org > February 2003

Re: TEST: editor update

From: Sean Bechhofer <seanb@cs.man.ac.uk>
Date: Mon, 24 Feb 2003 11:35:33 +0000 (GMT Standard Time)
To: Jeremy Carroll <jjc@hpl.hp.com>
cc: www-webont-wg@w3.org
Message-ID: <Pine.WNT.4.44.0302241125240.1608-100000@potato>

On Thu, 20 Feb 2003, Jeremy Carroll wrote:

>
> > > java.lang.ClassFormatError: org/apache/jsp/main_jsp (Code of a method
> > > longer than 65535 bytes).
>
> Hi Sean
>
> I reproduced your problem (on Linux rather than Windows).
> On closer inspection I had incorrectly identified the version of tomcat that I
> was using.
> I am using 4.0.4, I also did a clean install of 4.0.5 and that worked too.
>
> I have updated the download.tgz file, which includes the latest tests, and a
> fix to handle the non-ascii Unicode characters in one of the new tests.
> I updated INSTALL to be more detailed, and to specifiy the correct version of
> tomcat.
>
> I also fixed it to not include itself - so it is now half the size it was!
>
> Please let me know if you can get this working with tomcat-4.0.5
>
> I looked at using a war archive - forte had a make-a-war option but does not
> include the compiled jsp's in the war but leaves it up to tomcat to do that
> final stage. Since this is where the problem lay a war would not help.
>
> Please let me know if you can get it working.

Jeremy

I've now got it working. Having to compile stuff *is* a bit of a pain
though. You should be able to build the war archive yourself -- it's just
a jar file. If you have Tomcat all up and running and the necessary
classes compiled, you can do the following (from the Tomcat
installation directory):

cd webapps/wowg
jar cf wowg.war *
cp wowg.war ..

Now you've got a file wowg.war in the webapps directory. To test that it
works, shut down Tomcat, delete wowg directory (or perhaps move it
elsewhere :-), and restart Tomcat. Tomcat should notice the war in the
webapps, automatically expand it into a wowg directory and add the servlet
context.

Installation of the servlet is then simply a case of dropping wowg.jar
into the webapps directory.

I am using Tomcat 4.0.6 and JDK 1.4.1_01.

Better go and write some tests now I suppose....

Cheers,

	Sean



-- 
Sean Bechhofer
seanb@cs.man.ac.uk
http://www.cs.man.ac.uk/~seanb
Received on Monday, 24 February 2003 06:36:56 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:57:57 GMT