W3C home > Mailing lists > Public > www-voice@w3.org > October to December 2005

RE: VoiceXML 2.1: overriding parameter entities

From: Matt Oshry <matto@tellme.com>
Date: Mon, 7 Nov 2005 13:43:22 -0800
Message-ID: <B8E24C3AF01492459438BFA2D6ECBF730450FA11@EXCH.sea.tellme.com>
To: "Bjoern Hoehrmann" <derhoermi@gmx.net>
Cc: <www-voice@w3.org>

Bjoern,

The Voice Browser Working Group (VBWG) is now completing its resolution of issues raised during the review of the Candidate Recommendation version of VoiceXML 2.1 [1]. Our apologies that it has taken so long to respond.

Following the process described in [2] for advancement to Proposed Recommendation, this is the VBWG's formal response to the issues you raised:

The Voice Browser Working Group has discussed this issue and has decided to explicitly disallow definition of an internal subset when the VoiceXML 2.1 DTD is referenced. The language in Appendix C.3 will be updated accordingly.

Please indicate before 14 November 2005 whether you are satisfied with the VBWG's resolutions, whether you think there has been a misunderstanding, or whether you wish to register an objection.

If you do not think you can respond before 14 November, please let me know. The Director will appreciate a response whether you agree with the resolutions or not. However, if we do not hear from you at all by 14 November 2005, we will assume that you accept our resolutions.

Thank you,

Matt Oshry
Chief Editor, VoiceXML 2.1

[1] http://www.w3.org/TR/2005/CR-voicexml21-20050613/ 
[2] http://www.w3.org/2003/06/Process-20030618/ 

-----Original Message-----
From: www-voice-request@w3.org [mailto:www-voice-request@w3.org] On Behalf Of Bjoern Hoehrmann
Sent: Sunday, June 26, 2005 2:16 PM
To: www-voice@w3.org
Subject: VoiceXML 2.1: overriding parameter entities


Dear Voice Browser Working Group,

  http://www.w3.org/TR/2005/CR-voicexml21-20050613/ appendix C.1 states "The DTD subset must not be used to override any parameter entities in the DTD." It's not clear why this is required, it's seems acceptable to modify e.g. ATTLIST declarations and other parts of the DTD and it is not required that VoiceXML 2.1 are valid XML documents; it's difficult to verify whether this requirement is satisfied, I would suggest to drop it.

regards,
--
Björn Höhrmann · mailto:bjoern@hoehrmann.de · http://bjoern.hoehrmann.de Weinh. Str. 22 · Telefon: +49(0)621/4309674 · http://www.bjoernsworld.de
68309 Mannheim · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/ 
Received on Monday, 7 November 2005 21:43:28 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 30 October 2006 12:49:01 GMT