W3C home > Mailing lists > Public > www-validator@w3.org > November 2012

RE: Slowness on local install, just with some URLs

From: Mark Rogers <mark.rogers@powermapper.com>
Date: Sun, 4 Nov 2012 03:09:42 -0600
To: Jaime Iniesta <jaimeiniesta@gmail.com>, "www-validator@w3.org" <www-validator@w3.org>
Message-ID: <1F68EA0E0CBFBE44A9A64274E1AC01A11D00CAA3DC@DFW1MBX23.mex07a.mlsrvr.com>
I did quite a lot of digging through the code to diagnose the same problem a couple of years back.

The conclusion I came to then was the W3 validator was probably downloading the DTDs as well - but the performance hit was much smaller for validator.w3.org since the DTDs and validator are on the same LAN subnet (the validator may also have some caching mechanism for the downloaded DTDs like a local HTTP proxy)

You should be able to get the files from http://www.w3.org/MarkUp/DTD/ and save them into sgml-lib/REC-rdfa-syntax-20081014 (looked painful to do by hand since there are a lot to save, and modules include other modules). There's also a list of the files in sgml-lib/catalog.xml - might be possible to write small script to download the missing ones.

Best Regards
Mark Rogers - mark.rogers@powermapper.com
PowerMapper Software Ltd - www.powermapper.com 
Registered in Scotland No 362274 Quartermile 2 Edinburgh EH3 9GL 


-----Original Message-----
From: Jaime Iniesta [mailto:jaimeiniesta@gmail.com] 
Sent: 03 November 2012 22:09
To: www-validator@w3.org
Subject: Re: Slowness on local install, just with some URLs

That's it, Mark.

The page I'm trying to validate uses this doctype, that takes a lot of time to download:

http://www.w3.org/MarkUp/DTD/xhtml-rdfa-2.dtd

I installed the validator following the instructions on http://validator.w3.org/docs/install.html#install-download -- the DTD library that can be downloaded from there doesn't include this doctype.

http://validator.w3.org/sgml-lib.tar.gz

I guess the official validator.w3.org is using a more up-to-date doctype library than the one that can be downloaded, and that's why they're faster?

Does anyone know how to get a more up-to-date DTD library, or include this missing doctype in it?

Thanks!

2012/11/2 Mark Rogers <mark.rogers@powermapper.com>:
> Have you checked it can find a local copy of the DTDs? If it can't 
> find them, I think it falls back to downloading DTDs from w3.org  
> (which would result in validation working, but being very slow)
>
>
>
> Best Regards
>
> Mark Rogers - mark.rogers@powermapper.com PowerMapper Software Ltd - 
> www.powermapper.com
>
> Registered in Scotland No 362274 Quartermile 2 Edinburgh EH3 9GL
>
>
>
>
>
> From: Jon Cram [mailto:jon@webignition.net]
> Sent: 02 November 2012 08:31
> To: www-validator@w3.org
> Subject: Re: Slowness on local install, just with some URLs
>
>
>
> I'm seeing the same on a two local installs of the validator.
>
> On Ubuntu Desktop 12.10, both 64bit (my main machine) and 32 bit (a CI 
> server), validation takes a long, long time (longer than a minute). On 
> both machines I can retrieve the page markup with curl very quickly, 
> there's no network issue. The happens when validating by direct input, 
> so it's not a problem with retrieving the page markup through the validator.
>
> On Ubuntu Server 12.04 on a remotely-hosted dedicated server I'm not 
> getting the issue and the page validates just as quickly as it does at 
> http://validator.w3.org.
>
> I tried playing around with the doctype. Only HTML5 documents validate 
> quickly and this is explained by the fact that HTML5 validation is 
> deferred to the validator.nu validator and hence does not use the w3c validator.
>
> With doctypes that the w3c validator handles and even for simple 
> documents (just an empty head and body wrapped in an html element), 
> validation takes a very, very long time.
>
> I have no idea why. But I can at least confirm that I'm seeing similar 
> issues.
>
> On 01/11/12 21:39, Jaime Iniesta wrote:
>
> Hi, I'm having a weird issue with my local installations of the 1.3 
> validator.
>
>
>
> I'm validating this URL:
>
>
>
> http://www.jedermann-gruppe.de/cms/der-verein
>
>
>
> If I validate it on http://validator.w3.org it just takes 2 seconds to 
> respond, but when I do it on my local installation, it takes about a minute.
>
>
>
> Other URLs are fine, but all within this site are super slow. It does 
> not seem a connectivity issue, as I can browse this site fine, ping, etc.
>
>
>
> It does not happen on my local installation of validator.nu.
>
>
>
> I've tried on 3 different servers, with ubuntu 32 bits and 64 bits, 
> and different locations (a dedicated server and a pair of virtual 
> boxes on my machine).
>
>
>
> I can't find any error on the Apache logs, is there any other log to check?
> Please notice that the validation goes OK, it returns 7 HTML errors, 
> it's just slow.
>
>
>
> Can anyone with a local installation of the validator verify this?
>
>
>
> How can I investigate / solve this?
>
>
>
> Thanks!
>
>
>
> Jaime
>
>
Received on Sunday, 4 November 2012 09:10:04 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Sunday, 4 November 2012 09:10:06 GMT