W3C home > Mailing lists > Public > www-validator@w3.org > May 2012

Re: Facebook widget

From: Admin Stiefelettendamen.org <kontakt@stiefelettendamen.org>
Date: Wed, 9 May 2012 14:46:14 +0200
Message-Id: <E581F3FF-E7A4-472B-866E-7F92AD09FA29@stiefelettendamen.org>
To: www-validator@w3.org
Hi David,

can you manually edit the iframe from facebook?

I had a similiar problem with the integration with the Twitter-Follow-Button.
First, I used the official Button from the Twitter Website, but I had 6 Errors on w3.
After that, I've tried to use the "i-frame"-method, the code looked like this:

<iframe allowtransparency="true" frameborder="0" scrolling="no" src="http://platform.twitter.com/widgets/follow_button.html?screen_name=officetrend&show_count=true&button=blue&lang=de" style="width:300px; height:20px;"></iframe>

After that, there was only one error message, it was the same you've posted.
The solution was, to delete the "allowtransparency="true" attribute in the iframe. After that, there should be no errors anymore!

Hope it will work for you,

Alex
http://www.stiefelettendamen.org
Received on Wednesday, 9 May 2012 21:28:14 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 9 May 2012 21:28:23 GMT