W3C home > Mailing lists > Public > www-validator@w3.org > January 2007

I get this error message: Warning Line 106 column 1437: cannot generate system

From: mike horley <mike_horley@msn.com>
Date: Fri, 19 Jan 2007 15:18:34 +0000
Message-ID: <BAY101-F11D0BBDA069BA0D4A889A495A90@phx.gbl>
To: www-validator@w3.org

Hi,

I am sorry to bother you, but I am tearing my hair out trying to fix this 
problem and I was wondering if you could help please? I am a relative novice 
with PHP.

My URL is:

www.mortgages.jewelstrading.com

And I am just trying to validate the index.php file at this stage.

This is the first of 14 errors I get:

  1. Warning /Line 106 column 1437/: cannot generate system identifier
     for general entity "d".

     |...rketing.co.uk/cgi-bin/item.cgi?id=135*2*30&d=337&h=24&f=254">HBOS 
unveils new h|

     An entity reference was found in the document, but there is no
     reference by that name defined. Often this is caused by
     misspelling the reference name, unencoded ampersands, or by
     leaving off the trailing semicolon (;). *The most common cause of
     this error is unencoded ampersands in URLs* as described by the
     WDG <http://www.htmlhelp.com/> in "Ampersands in URLs
     <http://www.htmlhelp.com/tools/validator/problems.html#amp>".

     Entity references start with an ampersand (&) and end with a
     semicolon (;). If you want to use a literal ampersand in your
     document you must encode it as "&amp;" (/even inside URLs!/). Be
     careful to end entity references with a semicolon or your entity
     reference may get interpreted in connection with the following
     text. Also keep in mind that named entity references are
     case-sensitive; &Aelig; and &aelig; are different characters.

     If this error appears in some markup generated by PHP's session
     handling code, this article
     <http://www.w3.org/QA/2005/04/php-session> has explanations and
     solutions to your problem.

     Note that in most documents, errors related to entity references
     will trigger up to 5 separate messages from the Validator. Usually
     these will all disappear when the original problem is fixed.

I have tried all combinations of php.ini and .htaccess files in the current 
subdomain and in the main domain www.jewelstrading.com:

..htaccess
php_value arg_separator.output ;

..htaccess
php_value arg_separator.output &amp;

php.ini
arg_separator.output = ";"
session.use_trans_sid = 0

php.ini
arg_separator.output = "&amp;"
session.use_trans_sid = 0

I did at one time manage to get an error-free validation, but then found 
that I was getting an Internal Server error when I tried to look at the 
website. This was when I did not have the php.ini or .htaccess files in the 
top level.
I seem to have proved that I need a php.ini file in the top level but I 
cannot get this validation check to pass.

Hope you can help.

Many thanks


Mike Horley
Received on Sunday, 21 January 2007 23:43:41 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:23 GMT