W3C home > Mailing lists > Public > www-validator@w3.org > August 2007

(unknown charset) Re: Document passes when tested locally

From: (unknown charset) Семененко Егор <VitkovskyNET@yandex.ru>
Date: Tue, 14 Aug 2007 12:40:17 +0400
To: (unknown charset) www-validator@w3.org
Message-Id: <542471187080817@webmail34.yandex.ru>

>Hi,

>I have run a test on this document http://www.interdean.com/Default.aspx

>Locally which it passes no problem and all seems well but when it is

>uploaded to production server and I run the test again but not using local

>option it fails which I understand to be that the (name) attribute in the

>necessary form tag for asp.net pages is causing the problem.



>I have added <xhtmlConformence mode="strict" /> in  my web.config file which

>normally solves this problem. I don't understand why it would pass locally

>and not remotely. I also tested it on two servers to make sure it was not

>the problem of the server not reading the xhtml conformance tag in the

>web.config file but it was the same on both servers.



>Thank you, Chainy



Hi,



I have the same problem. The most interesting thing here that if you'll open your site in browser, copy the source code and check it in validator's direct input it will be passed too. It seems like the validator trying to compile .aspx pages itself and not using our web.config. 



Thank you,



Egor
Received on Thursday, 16 August 2007 16:39:47 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:25 GMT