W3C home > Mailing lists > Public > www-validator@w3.org > August 2007

Re: Invalid after having been balid for like 6 months?

From: olivier Thereaux <ot@w3.org>
Date: Fri, 3 Aug 2007 10:54:50 +0900
Message-Id: <2981445E-E93C-471E-8D1C-99CF451102E8@w3.org>
Cc: <www-validator@w3.org>
To: <herbert.glarner@bluewin.ch>

Dear Herbert,

On Aug 3, 2007, at 02:17 , Herbert Glarner wrote:
> For example, I try to validate http://herbert.gandraxa.com/herbert/ 
> hsh.asp

I can't even connect to your site, right now, so it's hard to see  
what's going on.

> Your validator all at a sudden says there are 8 errors, as per
> http://validator.w3.org/check?uri=http%3A%2F%2Fherbert.gandraxa.com% 
> 2Fherber
> t%2Fhsh.asp&charset=%28detect+automatically%29&doctype=Inline&group=0
>
> I can assure you that nothing changed withing those 6 months.

I can't say much before actually seeing validation results for that  
page, but the most likely scenario is: the markup of that page wasn't  
correct, you just didn't know it. And neither did the validator. The  
validator was recently upgraded with a more accurate engine, and now  
will spot errors it didn't use to.

> Now that you changed /your/ page, my pages do not validate anymore  
> as XHTML
> 1.1? Well, guess what: they still do.
>
> For the moment being, I prefer to just remove the links to your  
> validator
> until it was fixed.

Why are you angry? If you care about writing conformant Web content,  
you should perhaps be happy that the validator helps you spot more  
error?

And if indeed the errors come from a bug in the new validator, we'll  
be happy to fix that. But not being able to access your site doesn't  
help.

Regards,
-- 
olivier
Received on Friday, 3 August 2007 01:54:17 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:25 GMT