W3C home > Mailing lists > Public > www-validator@w3.org > May 2006

Re: Error when running logprocess.pl

From: Olivier Thereaux <ot@w3.org>
Date: Tue, 30 May 2006 13:15:41 +0900
To: Conor Stapleton <stapletonc@gmail.com>
Cc: www-validator@w3.org
Message-ID: <20060530041541.GA4751@w3.mag.keio.ac.jp>

Dear Conor,

Thank you for your message regarding the log validator. You are
reporting apparent bugs I was not aware of, so I hope we can diagnose
and fix them, with your help.

On Mon, May 29, 2006, Conor Stapleton wrote:
> The first issue is that the logprocess.pl script always uses default
> settings even when I specify a config file to use. To get the pl file to use
> my simple list of urls instead of server logs I had to modify the default
> setting in Config.pm.

I am curious to know what changes you had to make in Config.pm. Would it
be possible to send me a patch?

Knowing what version of the log validator you downloaded would be a good
info to have, too.
 
> [stapletonc@TOPCAT2][/cygdrive/c/temp/validation]=>logprocess.pl -f
> /cygdrive/c/temp/validation/logprocess.conf    (console)[14:5806-05-29]
> Reading logfiles: Done!
> Now Using the Basic module...
> Done!
> Can't locate object method "process_list" via package
> "W3C::LogValidator::SurveyEngine" at
> /usr/lib/perl5/site_perl/5.8/W3C/LogValidator.pm
> line 335.

This seems to point to a bug or at least a problem with the SurveyEngine
module. That module is experimental, and still has a number of bugs -
in most cases, you may not need it anyway, so I suggest you could edit
your config file (logprocess.conf) and comment out (make it start with #) 
that particular line.

> I installed all the modules with CPAN and they worked fine. The sub
> process_list seems to be all the modules and I cannot understand why I am
> getting the errors. If I remove the SurveyEngine from the
> logprocess.plfile, the next module throws the same error.

You mean logprocess.conf, right? It does not sound right that all
modules should throw this error - it's usually the sign of a syntax
error somewhere, and if you have managed to install the log validator,
then it certainly passed the 'make test', which would have caught such
errors... Perhaps the modifications you have made to Config.pm are the
cause of this?

Knowing more about how you installed the logvalidator, and what kind of
modifications you made (and how) would help, here.

Thanks.
-- 
olivier
Received on Tuesday, 30 May 2006 04:15:49 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:22 GMT