W3C home > Mailing lists > Public > www-validator@w3.org > May 2006

Error when running logprocess.pl

From: Conor Stapleton <stapletonc@gmail.com>
Date: Mon, 29 May 2006 15:10:26 +1000
Message-ID: <e5f76a0605282210v3acf5b00w962a7f5800f34441@mail.gmail.com>
To: www-validator@w3.org
Dear Sir/Madam,

I am encountering two problems when attempting to run the Log Validator.

I am running the script under cygwin, on a windows xp machine.

The first issue is that the logprocess.pl script always uses default
settings even when I specify a config file to use. To get the pl file to use
my simple list of urls instead of server logs I had to modify the default
setting in Config.pm.

The second more serious problem is as follows - the script executes and
gives the following error :

[stapletonc@TOPCAT2][/cygdrive/c/temp/validation]=>logprocess.pl -f
/cygdrive/c/temp/validation/logprocess.conf    (console)[14:5806-05-29]
Reading logfiles: Done!
Now Using the Basic module...
Done!
Can't locate object method "process_list" via package
"W3C::LogValidator::SurveyEngine" at
/usr/lib/perl5/site_perl/5.8/W3C/LogValidator.pm
line 335.

I installed all the modules with CPAN and they worked fine. The sub
process_list seems to be all the modules and I cannot understand why I am
getting the errors. If I remove the SurveyEngine from the
logprocess.plfile, the next module throws the same error.

Any help would be much appreciated.

Regards,
Conor Stapleton
Received on Tuesday, 30 May 2006 01:52:46 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:22 GMT