W3C home > Mailing lists > Public > www-validator@w3.org > May 2005

Re: Validator installation (onsgmls not supporting -n), help request

From: olivier Thereaux <ot@w3.org>
Date: Tue, 3 May 2005 12:03:42 +0900
Message-Id: <7455c75082219174378c1e04a15bf0a1@w3.org>
Cc: www-validator@w3.org
To: Alex Vincent <ajvincent@gmail.com>

Hello Alex,

On May 3, 2005, at 7:21, Alex Vincent wrote:
> I'm consistently getting this error message in our local installation
> of the W3C Markup Validator with the "miracle debug options":
> /usr/bin/onsgmls:E: invalid option "n"

> It's been suggested to me we were on an older version of onsgmls, but
> typing "onsgmls -v" returned:
> onsgmls:I: "OpenSP" version "1.5.1"

If you were the person dropping by on IRC, then I was the one 
suggesting that you had an older version of onsgmls, and I still think 
that's the case. My hunch is that you have the "old" onsgmls installed 
in /usr/bin/onsgmls and the new one in another path, possibly 
/usr/local/bin/onsgmls.

How to check:
- try '/usr/bin/onsgmls -v', not just 'onsgmls -v'. If it gives a 
version other than 1.5.1, then my assumption is correct.
- locate onsgmls (if your system has a locate DB) for different 
versions of the binary on your system

-- 
olivier
Received on Tuesday, 3 May 2005 03:03:50 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:19 GMT