W3C home > Mailing lists > Public > www-validator@w3.org > July 2004

Re: Weird problem

From: Nick Kew <nick@webthing.com>
Date: Thu, 8 Jul 2004 21:00:37 +0100 (BST)
To: Aleksi Suhonen <ams@modeemi.cs.tut.fi>
Cc: www-validator@w3.org
Message-ID: <Pine.LNX.4.53.0407082052130.985@hugin.webthing.com>

On Thu, 8 Jul 2004, Aleksi Suhonen wrote:

> http://modeemi.cs.tut.fi/~ams/uus/validator_error.html

404.

> I suspected that it might have been because of the usage of
> <script></script> instead of <script/>, but after I fixed that,

<script/> would be wrong.  Not necessarily invalid, but certainly wrong.
<script></script> is right.

> the validator just picked another random point in the document
> (the 'c' in 'type="text/css"' in fact) and gave the same error.

you didn't say what error.

> ...
>     <TITLE>

Capitals indicate an HTML doctype.  So the XML <script/> is bogus
in every way.

>        Axu's Homepage Version 3.0
>     </TITLE>
>       ATYPE CDATA text/javascript
>       ASRC CDATA http://www.modeemi.cs.tut.fi/~ams/apu/default.js
>     <SCRIPT>
>        > <link rel="StyleSheet" type="text

What's happening is (broadly speaking) explained in
http://valet.webthing.com/page/parsemode.html
Validate in "web" or "fussy" mode and use a strict doctype to get more
meaningful error reports.

> So the parser is definately being thrown off at some point.

That's a problem if you use a hopelessly loose doctype, designed for
legacy stuff in 1997/8.

-- 
Nick Kew
Received on Thursday, 8 July 2004 16:01:09 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:14 GMT