W3C home > Mailing lists > Public > www-validator@w3.org > September 2003

Re: Documentation error for beta Validator

From: Ville Skyttä <ville.skytta@iki.fi>
Date: Wed, 10 Sep 2003 22:07:14 +0300
To: www-validator@w3.org
Message-Id: <1063220834.4296.129.camel@bobcat.mine.nu>

On Wed, 2003-09-10 at 21:10, J. David Eisenberg wrote:

> On page http://validator.w3.org:8001/source/
> it says "...Perl. You'll need version 5.6.0 or newer."

Yes, this is correct.

> I downloaded the latest version of NET-IP (one of the dependencies 
> mentioned on that page) and tried to do:
> 
>    perl Makefile.PL
> 
> only to get this message:
> 
>    Perl v5.8.0 required--this is only v5.6.1, stopped at Makefile.PL line 
> 1.
>    BEGIN failed--compilation aborted at Makefile.PL line 1.
> 
> Suggestion: update the documentation, or specify which version of Net-IP 
> will allow building with Perl 5.6.x

I don't think we should get into the business of specifying all possible
Perl and module version combinations; they change pretty frequently thus
making such information very likely to bitrot often.  For example, a new
version of Net-IP which works with Perl 5.6 and newer might be released
tomorrow in case someone happens to do some backwards compatibility
fixing.  Or maybe it's just a spurious "require 5.008" in Makefile.PL.

Instead, I added a generic note about this, and how to deal with it:
http://dev.w3.org/cvsweb/validator/htdocs/source/index.html.diff?r1=1.22.2.14&r2=1.22.2.15&only_with_tag=validator-0_6_0-branch

By the way, based on a quick look, Net-IP 1.16 looks like it could work
with Perl 5.6.0 (and should work with validator too), but I'm unable to
verify either at the moment.  If you find a version of Net-IP that
doesn't work with the validator, just let us know.

Thanks for the feedback!
Received on Wednesday, 10 September 2003 15:09:10 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:09 GMT