W3C home > Mailing lists > Public > www-validator@w3.org > September 2001

Validation as a Browser Plugin for MSIE

From: Samuel RinnetmŠki <samuel.rinnetmaki@tothepoint.fi>
Date: Thu, 20 Sep 2001 09:19:26 +0300
Message-id: <fc.000f8d860010d85b3b9aca0059f407a1.10d8b0@tothepoint.fi>
To: nick@webthing.com
Cc: www-validator@w3.org
>The likely suggestion is that you do not have MSXML registered for some
>reason, or it's a version different to the one we expect.

I had the same problem as well.  (IE reported script error on line 15,
char 2	).
I ran IE 5.50.4522.1800 on WinNT 4.
>
>http://jibbering.com/msxml/  should prompt you to install version 3,

Yep, this worked for me.  (Although the first time I tried it only
prompted "null" and didn't proceed. On the second try, the installation
prompt appeared.) 
>
>which it certainly works with, I'll get the code changed to better report
>errors aswell, and we should track this one down.

Now, when I validate a document, I get a nice Site Valet Report.  The
first thing that bugs me is that the report window is "always on top". 
And, if I use the real browser window to navigate on another page, the
report window closes.  This is not the way the dialogs and windows
normally work.

The second bug is, that each time I try and validate a document, I always
get the results for the first page I validated.  I have to restart IE to
validate another document.

The third issue is, that the links on the Site Valet Report page open in
the same "ModelessDialog" window as the Report.  And that window lacks all
the normal browser functionality.  (Yes, there is a note indicating that
the links "don't work yet".  However, they "work" in a sense that you can
click on them and the contents of the page changes.)

Nice concept, however

	Samuel
---
Samuel Rinnetmäki
samuel.rinnetmaki@tothepoint.fi
Received on Thursday, 20 September 2001 02:29:50 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:13:59 GMT