W3C home > Mailing lists > Public > www-validator@w3.org > September 2001

Re: Mysterious character encoding detection

From: Bjoern Hoehrmann <derhoermi@gmx.net>
Date: Wed, 19 Sep 2001 04:24:47 +0200
To: Per Angstrom <per.angstrom@autark.se>
Cc: www-validator@w3.org
Message-ID: <d80gqt8nf90de3uqrj6n80v24r3gngr4fc@4ax.com>
* Per Angstrom wrote:
>I get a mysterious error when trying to validate www.cisco.com:
>'The detected character encoding was "inline". The error was ""'.
>
>The request is encoded like this: <URL
>http://validator.w3.org/check?uri=http%3A%2F%2Fwww.cisco.com%2F&charset=%28detect+automatically%29&doctype=Inline 
>>.

Hm, I didn't take a look at the current code, this may be caused by

  <META HTTP-EQUIV="Content-Type" CONTENT="text/html">

on this page, but I fear it isn't.

>Pressing the Revalidate button on the results page will generate 
>another erroneous detection: 'http'.

Validating the result page shows up errors :-)

>I'm curious to know where the error comes from.  I'm sorry if this is a 
>well-known problem, but I could not find any reference to it.

It seems we finally have some new bugs ;-)
-- 
Björn Höhrmann { mailto:bjoern@hoehrmann.de } http://www.bjoernsworld.de
am Badedeich 7 } Telefon: +49(0)4667/981028 { http://bjoern.hoehrmann.de
25899 Dagebüll { PGP Pub. KeyID: 0xA4357E78 } http://www.learn.to/quote/
Received on Tuesday, 18 September 2001 22:26:20 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:13:59 GMT