W3C home > Mailing lists > Public > www-validator-css@w3.org > August 2004

Bug of "/css-validator/check/referer" in IE6 with XP Chinese version

From: Janyckee Joz <joo@sjtu.edu.cn>
Date: Fri, 6 Aug 2004 06:24:15 +0800
Message-ID: <019e01c47b3a$f3bebda0$0700000a@zezoz>
To: <www-validator-css@w3.org>
I use http://jigsaw.w3.org/css-validator/check/referer on my page to link to the W3C CSS validator.
But when I clicked the link in IE6, the validator gave the following message with lots of question 
marks instead of the Chinese characters(I am using Windows XP in Chinese). I tried to using 
different encoding such as "Unicode(UTF8)" or re-selecting the "Simplied Chinese" encoding. But 
it still displayed question marks.

If I tried to use
http://jigsaw.w3.org/css-validator/validator?uri=http://jozz.vicp.net/whizzoff.com/index.ascii.html

to get feedback, I got the correct Chinese message.

I also checked the link http://jigsaw.w3.org/css-validator/check/referer in Mozilla or Opera. And it gave 
me normal English feedback as desired.

Maybe it is a bug of the CSS validator in the internationalization. I also checked XHTML validator
http://validator.w3.org/check?uri=referer 
in IE6, it gave good English result (NOT Chinese result in the above link)

My environment:
System: Windows XP Pro (Simplied Chinese)
Browser: IE6.0.2800.1106...

============================
W3C CSS ?????? http://jozz.vicp.net/whizzoff.com/index.ascii.html

  a.. ????????????? 
  b.. ????????
?????????
?????????????????! 

????????????????????? ???????????????????????? ??????????????HTML???

 
<p>
 <a href="http://jigsaw.w3.org/css-validator/">
  <img style="border:0;width:88px;height:31px"
       src="http://jigsaw.w3.org/css-validator/images/vcss" 
       alt="Valid CSS!" />
 </a>
</p>???????????????????????????? ??????????????????????????? 


Received on Thursday, 5 August 2004 18:22:07 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 27 June 2012 00:14:15 GMT