W3C home > Mailing lists > Public > www-svg@w3.org > October 2011

renaming SVGPathSegList

From: Cameron McCormack <cam@mcc.id.au>
Date: Fri, 21 Oct 2011 14:09:45 -0400
Message-ID: <4EA1B569.4090701@mcc.id.au>
To: 'www-svg' <www-svg@w3.org>
As part of improving the SVG DOM, I think we should consider renaming 
SVGPathSegList to SVGPath (or perhaps even just Path).  SVGPathSegList 
is unwieldy if we want to add a constructor to the interface so that 
authors can do

   var p = new SVGPath("M100,100 ...");

Does anyone think there would be any compatibility risk with this?
Received on Friday, 21 October 2011 18:11:59 GMT

This archive was generated by hypermail 2.3.1 : Friday, 8 March 2013 15:54:49 GMT