W3C home > Mailing lists > Public > www-svg@w3.org > May 2005

Re: SVG12: getPresentation* naming

From: Dean Jackson <dean@w3.org>
Date: Sat, 21 May 2005 19:41:31 -0400
To: Bjoern Hoehrmann <derhoermi@gmx.net>
Cc: www-svg@w3.org
Message-ID: <20050521234131.GD1329@homer.w3.org>

On Sun 22 May 2005, Bjoern Hoehrmann wrote:

> * Dean Jackson wrote:
> >>   In http://www.w3.org/TR/2005/WD-SVGMobile12-20050413/svgudom.html the
> >> proposed getPresentation* methods are poorly named. The names are much
> >> too long and inconsistent with SVG 1.1 where getPresentationAttribute
> >> behave very different from the proposed methods, and with SVGAnimated*
> >> interfaces which have a animVal attribute rather than presVal. Please
> >> change the names of these operations to something much shorter and more
> >> consistent with SVG 1.1. Possible naming would be getAnim* but that de-
> >> pends on what value these operations return in SVG "Full" as I wrote in
> >> another comment.
> >
> >We discussed this and decided to keep the current names. We prefer
> >descriptive names over shorter, less clear names. Also, the animVal
> >attribute has caused a lot of confusion over the past few years.
> 
> I strongly object to this response. First, SVG 1.1 has many abbreviated
> names so this "consistency" argument is unsound. 

I didn't make an argument about consistency, I made an
argument about clarity. If you meant "clarity" then 
I have to disagree strongly with abbreviated names. The
fact that SVG 1.1 has some unclear methods names doesn't 
mean we should continue to be unclear.

> Second, the Working
> Group failed to address my concern that the naming is misleading. 

SVG 1.1 has getPresentationAttribute
SVG 1.2 has getPresentationTrait

Are you arguing that Trait and Attribute are so similar
that it will confuse people? (not picking a side, just asking
since I want clarity)

Oh, maybe I misread your comment. Do you suggest getAnimatedTrait?
On first glance I agree with you. (Or getAnimTrait? I'm not a fan
of that)

> Third,
> the Working Group failed to address my concern that the methods are too
> underspecified to name them properly, substantive review comments like
> e.g.
> 
>   http://www.w3.org/mid/4250f647.197089906@smtp.bjoern.hoehrmann.de
>   http://www.w3.org/mid/4322a5d6.137820203@smtp.bjoern.hoehrmann.de
> 
> have been ignored by the Working Group. 

Ouch! That's the second time in a few days someone has
claimed we "ignore" issues. In this case, we have not yet
responded, but that is not because we're ignoring it.

> And last but not least I would
> like to point out that the Working Group could update specifications
> if certain features cause a lot of confusion,

Indeed. And this is one of the reasons we're creating a
new DOM interface - the SVG 1.1 interface was very confusing and
therefore rarely implemented. 

>  or maintain educational
> material like FAQs that remove such confusion.

Agreed.

> 
> Once all issues on trait access have been formally addressed I will
> reconsider my position or express more clearly why I find this naming
> unacceptable.

Thanks.

Dean
Received on Saturday, 21 May 2005 23:41:34 GMT

This archive was generated by hypermail 2.3.1 : Friday, 8 March 2013 15:54:30 GMT