W3C home > Mailing lists > Public > www-svg@w3.org > October 2001

RE: embed svg in html

From: Michael Bierman <mbierman@adobe.com>
Date: Thu, 11 Oct 2001 10:05:13 -0700
To: "Uzma Shaffi" <u.shaffi@har.mrc.ac.uk>, <ronan@roasp.com>, <www-svg@w3.org>
Message-ID: <NIEELDHFCPFLANKKAHOEIEAPDDAA.mbierman@adobe.com>

  -----Original Message-----
  From: www-svg-request@w3.org [mailto:www-svg-request@w3.org]On Behalf Of Uzma Shaffi
  Sent: Thursday, October 11, 2001 3:45 AM
  To: ronan@roasp.com; www-svg@w3.org
  Subject: Re: embed svg in html


    
  Im not using Netscape Navigator,because it doesnt support svg. 
Uzma, 

Forgive me, but what do you mean that NN doesn't support NN? I assume you are using Adobe SVG Viewer, which does support Netscape. 

Michael
   I have used same <embed > codes just like yours, but its not updating my svg map dynamically. I have to press "refresh" each time I clicked on any part of the map. 
  <object> code doesnt work in same way. 
  can't we just have svg codes in servlets without embeding it first in html/xhtml?? I mean we can just print out svg, instead of saving it each time its send to client.Then it may create concurrency problems,if multi users are accessing same file at same time. Wouldn't it be overwritten then? 

  Uzma 
    

  ronan@roasp.com wrote: 

     I stand corrected. 
    It may not be your method but your browser giving problems at the client end. 

    I've got the latest version of the plug-in on a machine and an older version on another. It seems that the new version has a problem with rendering the svg I generate. That particular SVG is dynamic and has url links to other documents, and the links show up in the drawing window, but the rendering does not take place. 

    Anybody else having this problem? 

    Here is the offending site: 

    http://roasp.com/cgi-bin/new_svg/examples/svgtest2.pl 

    viewable in IE5 / svgexe beta 2, but not visible in NS4.7 beta 3 (candidate release). 

    also, 

    http://roasp.com/svg/index2.html , an html document with static and dynamic svg in it. Same problem. 

    Beware of the <object > tag. Many corporate firewalls block that tag. 

    Here is my embed implementation 

    <EMBED SRC="images/header.svg" 
      NAME="SVG1" width="760" height="100" 
      TYPE="image/svg-xml" 
      PLUGINSPAGE="http://www.adobe.com/svg/viewer/install/"> 


    <EMBED SRC="http://roasp.com/cgi-bin/new_svg/examples/svgtest2.pl" 
      NAME="SVG2" width="760" height="100" 
      TYPE="image/svg-xml" 
      PLUGINSPAGE="http://www.adobe.com/svg/viewer/install/"> 

    This seems to be the same implementation as yours 





      -----Original Message----- 
      From: www-svg-request@w3.org [mailto:www-svg-request@w3.org]On Behalf Of Uzma Shaffi 
      Sent: Thursday, October 11, 2001 12:05 PM 
      To: www-svg@w3.org 
      Subject: embed svg in html 
       
      Hello , 
      I m using adobe plugin, and internet explorer browser. 
      Im emding svg file in my servlets like this: 

      out.println("<embed  width=\""+Integer.toString(maxX)+"\" height=\""+Integer.toString(maxY)+"\" src=\"http://www.dev.mgu.har.mrc.ac.uk/svgfiles/map"+zoomRange+".svg\" TYPE=\"image/svg-xml\" pluginspage=\"http://www.adobe.com/svg/viewer/install/\"></div>"); 

      this code comes in <body> of the html. 

      how can I use OBJECT in it??? 

      thanks 
      uzma

Received on Thursday, 11 October 2001 13:07:43 GMT

This archive was generated by hypermail 2.3.1 : Friday, 8 March 2013 15:54:21 GMT