W3C home > Mailing lists > Public > www-style@w3.org > December 2013

Re: [css-values] interpolate() function

From: Dirk Schulze <dschulze@adobe.com>
Date: Tue, 3 Dec 2013 12:17:33 -0800
To: "Tab Atkins Jr." <jackalmage@gmail.com>
CC: Lea Verou <lea@verou.me>, www-style list <www-style@w3.org>
Message-ID: <244DF31D-AE05-4590-8F41-98D1FEEA7472@adobe.com>

On Dec 3, 2013, at 7:55 PM, Tab Atkins Jr. <jackalmage@gmail.com> wrote:

> On Tue, Dec 3, 2013 at 10:44 AM, Lea Verou <lea@verou.me> wrote:
>> On Dec 3, 2013, at 00:39, Tab Atkins Jr. <jackalmage@gmail.com> wrote:
>>> Yeah, I've thought about this before.  I'm in favor of it.
>> 
>> Great! Anyone else?
>> 
>> Btw, I've noticed many authors don't know what interpolation means, even native English speakers, so perhaps we need a different name than interpolate(). I've thought of combine() but it doesn't make sense for e.g. lengths. Definitely not cross-fade() though, that's confusing even for images (for which it was designed).
> 
> More synonyms for combine() could be blend() or mix().

What about cross-fade()? Oh wait...

> 
> Ultimately, we're stuck with either using a name that's not perfect
> for all types, or using a name for the generic operation that many
> people won't understand.
> 
> ~TJ
> 
Received on Tuesday, 3 December 2013 20:17:59 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:39:17 UTC