W3C home > Mailing lists > Public > www-style@w3.org > December 2013

Re: [css-values] interpolate() function

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Tue, 3 Dec 2013 10:55:47 -0800
Message-ID: <CAAWBYDBbjL+qLVU21OM19OnnFQHoBB2rhDTVktFMd1rEVGXMAA@mail.gmail.com>
To: Lea Verou <lea@verou.me>
Cc: www-style list <www-style@w3.org>
On Tue, Dec 3, 2013 at 10:44 AM, Lea Verou <lea@verou.me> wrote:
> On Dec 3, 2013, at 00:39, Tab Atkins Jr. <jackalmage@gmail.com> wrote:
>> Yeah, I've thought about this before.  I'm in favor of it.
>
> Great! Anyone else?
>
> Btw, I've noticed many authors don't know what interpolation means, even native English speakers, so perhaps we need a different name than interpolate(). I've thought of combine() but it doesn't make sense for e.g. lengths. Definitely not cross-fade() though, that's confusing even for images (for which it was designed).

More synonyms for combine() could be blend() or mix().

Ultimately, we're stuck with either using a name that's not perfect
for all types, or using a name for the generic operation that many
people won't understand.

~TJ
Received on Tuesday, 3 December 2013 18:56:33 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:39:17 UTC