W3C home > Mailing lists > Public > www-style@w3.org > August 2013

Re: [selectors4][naming] Naming the drag-and-drop pseudo-classes

From: Brad Kemper <brad.kemper@gmail.com>
Date: Sat, 17 Aug 2013 21:43:32 -0700
Message-Id: <038E7778-DEF4-4219-8EC2-4EA7AE858411@gmail.com>
Cc: www-style list <www-style@w3.org>
To: "Tab Atkins Jr." <jackalmage@gmail.com>
On Aug 15, 2013, at 11:02 PM, "Tab Atkins Jr." <jackalmage@gmail.com> wrote:

> One particular custom suggestion jumped out at me as an interesting
> possibility: a :drop([active | valid | invalid]) function pseudoclass.
> This not only puts the "drop" part first, which was called out as a
> good thing in several of the feedback entries, it also gives a natural
> extension point.
> 
> So, I suggest we make a final decision for this at next week's call,
> and choose between:
> 
> 1. :current-drop / :valid-drop / :invalid-drop
> 2. :active-drop / :valid-drop / :invalid-drop
> 3. :drop(active) / :drop(valid) / :drop(invalid)

You don't really need the parentheses in order to get the common word first, nor to make it extendable. You could just have: 

:drop-active / :drop-valid / :drop-invalid / :drop-whatever

I'm not a big fan of parentheses in pseudo-classes, and they really aren't needed here.
Received on Sunday, 18 August 2013 04:44:01 UTC

This archive was generated by hypermail 2.3.1 : Sunday, 18 August 2013 04:44:01 UTC