W3C home > Mailing lists > Public > www-style@w3.org > April 2013

Re: [css-variables][naming] Renaming 'var'

From: Anselm Hannemann <info@anselm-hannemann.com>
Date: Sun, 14 Apr 2013 14:43:35 +0200
To: Brian Kardell <bkardell@gmail.com>
Cc: Simon Sapin <simon.sapin@exyr.org>, fantasai <fantasai.lists@inkedblade.net>, www-style@w3.org, Bjoern Hoehrmann <derhoermi@gmx.net>
Message-ID: <5D92EA491B964329A31B5AD987733618@anselm-hannemann.com>
On Sunday, 14. April 2013 at 13:59, Brian Kardell wrote:
> On Apr 14, 2013 3:26 AM, "Simon Sapin" <simon.sapin@exyr.org (mailto:simon.sapin@exyr.org)> wrote:
> >
> > Le 14/04/2013 00:57, Bjoern Hoehrmann a écrit :
> >
> >> * fantasai wrote:
> >>>
> >>> So, at Rename the Web Forward [1], Sylvain and I concluded that it
> >>> just might be better to use 'set-' as the prefix and 'get()' as the
> >>> function name instead of 'var-' and 'var()'.
> >>>
> >>> p {
> >>>    set-???: green;
> >>>    background: get(???);
> >>> }
> >>>
> >>> This takes us closer to "custom properties" than "variables",
> >>> (and has the added bonus of not being an abbreviation!)
> >>
> >>
> >> Well, `get` and `set` as used here are imperative, while CSS tries to be
> >> a declarative language, so this seems rather confusing to me.
> >
> >
> >
> > I like loosing the Variable terminology, but I share Björn’s concerns. In particular, this is gonna be awkward:
> >
> >   style.getPropertyValue('set-foo')
> >
> > --  
> > Simon Sapin
> >  
> Fwiw, iirc the imperative argument, what simon just mentioned and also the fact that "get" as a function could have numerous interpretations all came up when François and I forked a draft and began pursuing "custom properties" and we thought it was less important than just clearly describing them as such, so we avoided and went another way.  I didn't love that way either.
> I can see arguments against get/set.  I am ok with var/var or even a mix of the two.  Despite all of this, i find get/set personally most intuitive and enforcing the idea of custom properties.
>  
>  
>  

I can understand the implication of the draft but don't like it. It can confuse users as it no longer is the same terminology. For instance it is harder to batch-identify variables and its calls as one must then use an OR argument to find the calls and sets.
Also many users might be confused get() means to get some source like CLI get does. Surely we have url() for this but newcomers and people who don't know of CSS variables might think it is a new GET method which it isn't.

- Anselm Hannemann
@helloanselm
Received on Sunday, 14 April 2013 12:44:00 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:39:10 UTC