W3C home > Mailing lists > Public > www-style@w3.org > April 2013

Re: [css-variables][naming] Renaming 'var'

From: Brian Kardell <bkardell@gmail.com>
Date: Sun, 14 Apr 2013 07:59:59 -0400
Message-ID: <CADC=+jc5edYApeM8fW4kaPBmyrBu28sC1D_zaX-bwhEhxdpQvg@mail.gmail.com>
To: Simon Sapin <simon.sapin@exyr.org>
Cc: fantasai <fantasai.lists@inkedblade.net>, www-style@w3.org, Bjoern Hoehrmann <derhoermi@gmx.net>
On Apr 14, 2013 3:26 AM, "Simon Sapin" <simon.sapin@exyr.org> wrote:
>
> Le 14/04/2013 00:57, Bjoern Hoehrmann a écrit :
>
>> * fantasai wrote:
>>>
>>> So, at Rename the Web Forward [1], Sylvain and I concluded that it
>>> just might be better to use 'set-' as the prefix and 'get()' as the
>>> function name instead of 'var-' and 'var()'.
>>>
>>> p {
>>>    set-???: green;
>>>    background: get(???);
>>> }
>>>
>>> This takes us closer to "custom properties" than "variables",
>>> (and has the added bonus of not being an abbreviation!)
>>
>>
>> Well, `get` and `set` as used here are imperative, while CSS tries to be
>> a declarative language, so this seems rather confusing to me.
>
>
>
> I like loosing the Variable terminology, but I share Björn’s concerns. In
particular, this is gonna be awkward:
>
>   style.getPropertyValue('set-foo')
>
> --
> Simon Sapin
>

Fwiw, iirc the imperative argument, what simon just mentioned and also the
fact that "get" as a function could have numerous interpretations all came
up when François and I forked a draft and began pursuing "custom
properties" and we thought it was less important than just clearly
describing them as such, so we avoided and went another way.  I didn't love
that way either.

I can see arguments against get/set.  I am ok with var/var or even a mix of
the two.  Despite all of this, i find get/set personally most intuitive and
enforcing the idea of custom properties.
Received on Sunday, 14 April 2013 12:00:27 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:39:10 UTC